System requirements

Arrigo Local

Arrigo Local requires a 64-bit Windows version to install and run.

Arrigo Local Installer requires PowerShell 5 or newer to run.

Arrigo Local is tested and supported on the following OS’es:

Chromium Installer

Chromium Installer is tested and supported on the following OS’es:

You can also install on these OS’es, but we do not actively test the installer or the browser on them:

Chromium Installer cannot be installed or run on Windows 7 / Windows 2008 Server or earlier.